This forum is now read-only

To login to the new support channel and community forums, go to the Support Portal

(2014) L1 (watertank) intermittant water refill / warming up failure

Hi y'all!

I'm sorry if this subject has been, at least in part, already touched upon, and I've read it all, yet I would like to be precise.

When, in the morning, I switch on the machine, the water tank is always full of water.
Typically, it starts pumping, this goes on for a while and then it stops.

There are two possibilities,
(1) the red light goes on, which indicates everything is OK, and the machine heats up.

(2) but, too often, I hear the very faint "reset" beeps, and the red light doesn't light up.

In that case, I reset and, often the pump kicks in again, stops, red light on...OK.

What would be the reason for this erratic behavior?

So far, this hasn't prevented me from setting (typically) what I consider to be great espresso using this beautiful machine.
Is there a risk of the machine giving up? Should I act proactively?

Thanks for your appraisal.


  • hi paul

    i understand that your machine is a 2014 L1

    the alarm that you are hearing under scenario (2) sounds when the pump is unable to raise the water level in the boiler to the maximum level as determined by the level probe in the boiler within a defined period of time, perhaps 30 seconds from memory

    given the age of your machine i think the most likely explanation is that the vibratory pump is getting tired

    i recommend that you replace it

    you can find the pump here:

    in the permanent file within the Support section of this website you can find comprehensive, easy to follow, instructions on how to install the pump thanks to Peter Redrup

    kind regards

  • Hi Reiss, well, the pump I think is working fine (I unscrewed the pressure hose, hooked the pump up using a power cable and two short lengths of very stiff insulated copper wire, no hands necessary to connect to power), the pump shoots out water at what would seem to be sufficient debit, so the origin of the problem could be elsewhere, I suspect some blockage somewhere, perhaps the solenoid valve. I tried to take it apart (as per a video you made), unfortunately I wan unable to disassemble it completely (a thin copper nut got rounded...), so I'll order a new one (complete with fittings for the 2014 L1) from you.

    As things are now, I can't use my 2014 L1 machine: there seems to be no (or far too little) water being pumped into the pressure vessel, and when I pull the lever, all I get is (some) steam, so I prefer to shut operations down. until I get it all figured out.

    Other than that, would you have any suggestions? I've prepared a list of items to buy from you and I'd like, if possible, to be reasonably certain I won't have to order more in case the problem would be elsewhere...

    What is your appraisal, Reiss? Thanks!
  • Hi Reiss, and thank you.

    I unscrewed the braided hose from the pump, which I (safely) wired to the wall outlet, and put the pump water output into a separate container: the pump seems to work fine, with a decent output of water.

    I tried to dismantle (per that video you made) the solenoid with the valve from the 2014 L1 machine, got it off, but didn't manage to completely dismantle the valve into its separate entities (a copper nut got rounded...), so now I'll order a new solenoid valve, complete with the brass fittings for a 2014 L1.

    I did put the above items back together, but when I pull the group lever down (and back up), no water comes out, only some limited steam, leading me to abort everything until I get this sorted out...

    Before putting in my order for spares, could you please evaluate the situation and advise on the possibility (and likelyhood) of alternate reasons for the problems? Thanks in advance!
  • Hi again, thanks Reiss,

    OK - I undid the braided hose at the pump end, provided a safe separate electric power line to the pump, and I confirm it pumps a decent dose of water. In other words, the pump seems to work to satisfaction.

    I dismounted the inlet solenoid assembly, in order to try and clean it (as per your relevant video). However, due to rounding a slim copper nut, I was unable to completely disassemble the valve, so I put it back on. Now, when I turn the machine on, it heats up (red light) but, when I pull the handle down (and back up) no water comes out, only steam. The pump doesn't jump into action at all...

    This was enough for me to abort any further attempts to make coffee. I've got an order lined-up for, i.a. a complete entry solenoid + valve, with fittings for the 2014 L1, and some group seals etc. but before shooting it off to you (I won't be home for the next few days), I invite your appraisal, enabling me to, if necessary, include what you may suggest.

    Thanks for your appraisal, looking forward to any comments and suggestions!

  • hi paul

    yes, your approach is sound - you will have an obstruction in the solenoid valve

    replacing the solenoid valve should get you back in business

    as always i recommend that customers buy seals, screens, baskets and any other items that might be tiring in one hit and stick them in a drawer until needed; the delivery cost will not be any greater than ordering a single item

    kind regards

  • Thanks very much for your help, Reiss. I'll report back when I've received and installed the spares!
Sign In or Register to comment.