This forum is now read-only

To login to the new support channel and community forums, go to the Support Portal

GFCI tripping




    Reiss, thanks for your help. If anyone is reading this in the future and needs to remove the immersion element, a "TEKTON 1/2 Inch Drive x 38 mm 6-Point Socket | SHD22138" was $10 on Amazon and did the job.
  • super leo
    thank you for letting us know how the story ended
  • bad news

    Until this morning, everything was working perfectly. I have not moved or opened the machine. But today the GFCI was tripped again. I disconnected the heating element from all the wires and got out the multimeter. Like last time, I again found continuity between the heating element terminals and the boiler. (10 to 30 ohms) Normal continuity of 12 ohms across the terminals.

    The ceramic insulators looked OK, so I screwed the element out to get a better look. To my inspection I don't see anything wrong. But other than this element, I see no other obvious culprit.

  • hi leo

    apologies for the delayed reply

    i havent seen an element fail so soon before, but that has to be due to a crack in the ceramic to line up with your description i think

    with the boiler removed is there continuity between the element and the brass mounting thread?

    in your images one of the terminals looks to lie very close to the inside of the brass head that the socket fits onto

    kind regards


  • Yes, when I remove the element there is continuity between the terminals and the brass mounting threads.

    You are correct, one of the terminals is closer to the rim than the other. It's not bent; the whole thing is off center.

  • it can only be a cracked ceramic insulator. ill try to get another heading your way today. same address as last time?

    i assume all you need is element & gasket?


  • That's all I need, thanks!

  • edited December 2020

    The new element arrived. Good news and bad news.

    The good news is that the GFCI does not trip any more.

    The bad news is that the machine now trips my circuit breaker after a couple of minutes. I've done some tinkering but have not found an obvious explanation.

    The old element has about 20 ohms of resistance between the terminals and the brass threads. The new one is around 600 kilo-ohms. I'm not sure if that's normal or not, but clearly the old one was faulty. When screwed in, the multimeter shows resistance from terminals to boiler of about 1 mega-ohm.

    I confirmed that the new element is the 120V version. 12 ohms across the terminals, as expected.

    The gasket is in place. I put a tiny bit of the usual Loxeal grease on it but otherwise did nothing special when installing the element.

    Regarding the circuit itself, 1. the machine will trip any circuit I try and 2. the circuit is a 20A circuit connected to almost nothing else (a single light bulb and a wifi router) and handled a 2200W hair dryer without tripping.

    The machine is plugged in directly, no extension cord or Wemo. The cord and plug appear normal.

    With all panels removed, I inspected all wires in the machine. The on/off switch also looks good, and does not get hot after the circuit breaker trips. There was a tiny bit of water at the bottom of the chassis, (I splashed a little water when I pulled out the reservoir to install the new element) but I ran a strong fan over everything for an hour to dry things out, with no benefit. Since running the fan, everything has stayed dry -- I don't think that anything is leaking.

    Although I do not think they are the problem, I removed the thermal fuse and wireless module, with no benefit.

    If the heating element is disconnected, the machine will not trip the circuit breaker. The pump works normally.

    From a coldish start, the circuit breaker trips after about 2-3 minutes. If the boiler is hot, it can trip after 5-10 seconds.

    I removed the element to make sure it was installed correctly, and also confirmed that the boiler is full of water.

    I took a look inside the Sirai P-stat, which is suspicious to me because of the association between a hot boiler and tripping the breaker, but I did not see anything clearly out of the ordinary. There's one part on the right with a little corrosion and brown discoloration on the side, which is unchanged from the picture I took in July (earlier in this thread). I took a picture:

  • what is the stamping on the element? it will be on the side of one of the nut faces. i.e. have we sent you the wrong element, eg a 240V/2400W one instead of a 120V/1400W one??

    kind regards


  • 120V/1400W. I checked before installing it.

  • I checked again just now. "120 V 1400 W"

  • it is reassuring that we have sent you the correct element, which would draw about 11.67A on 120V

    i am trying to figure out how that would pop a 20A breaker

    if you observe the Sirai pressure switch opening and closing are all 3 contact pairs releasing cleanly, or is one pair sticking? Has a screw/other foreign body fallen down into the body of the switch, creating a short circuit?

  • The machine doesn't get hot enough to trigger the P-stat. I fiddled with the contact pairs and they all seem the same, nothing is sticking and they move easily. No loose objects inside. I haven't opened it up since July when I had the original problem. (In fact I haven't opened the machine at all since then.)

  • I'm going to try watching the P-stat to see if something happens right before the circuit breaker trips.

  • are the two wires that terminate on the Sirai secure? what about the two loop wires that bridge the current load over to the second pair of terminals. if you try wiggling the 6 wire ends involved are they all secure?

  • The boiler was barely warm when I turned it on. The circuit breaker tripped after 1 minute 40 seconds. I saw nothing inside the P-stat when it happened.

  • I'm not exactly sure which wires you are referring to, although I've inspected every wire in the machine. At the bottom of the Sirai, there are 3 red wires that come out, and a loop of red wire that comes out and goes back in. They are all secured to something.

  • yes but when you turn the machine the Sirai switch is open. it only closes when you see the red light on the front panel turn on.

  • I've never seen the innards of the Sirai in action so I'm not sure how it's supposed to look. But nothing changes when I turn the machine on, even after the red light turns on. It looks the way it does in the picture above. Is the black bar supposed to move away from the contacts?

  • it should like the the image at step 14 of the above document; two wires entering and each of those wires with a loop wire on it to spread the current load over two terminals instead of just one.

  • It's hard for me to get a good view of those wires, but it appears to be configured the same way.

    I never had this problem before, so I'm suspecting that the problem is related to the new element, or repositioning of the machine while installing the new element. I don't think that any wires have come loose.

  • My multimeter has an ammeter (that I've never used before) so I tried it out. The red and blue wires to the heating element had 11 A (which was stable up to the circuit breaker tripping). Two of the P-stat wires were also around 11 A. The third one, which goes the other way (away from the Gicar) did not have detectable current.

  • edited December 2020

    More data points

    I timed it this morning from a completely cold start and it tripped at 3 minutes 45 seconds. It seems like a short that only occurs at a certain temperature. I don't recall how long it takes the boiler to start building pressure but the pressure gauge is at zero when this happens.

    I checked the resistance at the heating element immediately after, and it was unchanged. (ie., warming up doesn't seem to have produced a short within the heating element.)

    For the next experiment, I turned it on and waited for the breaker to trip. I quickly reset the breaker and restarted the machine, and it tripped again in a couple of seconds. I then again quickly reset the breaker, disconnected the heating element, and restarted it again. The machine stays on without any issues and the pump works normally when I pull the lever.

    Also, I had not been paying much attention to the digital module, but I noticed that it had a "check expvalve" message today. But from what I can tell from the forum, this is not an issue.

  • edited December 2020

    Having thought about it some more:

    1. The machine was working normally until a few days ago.
    2. Nothing has been changed other than the heating element, which was replaced in a routine way.
    3. The problem only manifests when the new heating element is powered.
    4. The problem only manifests when the machine is warm, but happens early enough that only the boiler is warm, and the P-stat is probably not experiencing a significant change compared to the time of turn-on.
    5. Inspection of the rest of the machine reveals no obvious changes or defects.

    It seems that the new heating element is the most likely culprit, even if the multimeter can not detect a problem.

  • hi leo

    i dont dispute your logic

    the only thing is that from my side of the fence we have almost no issue with the heating elements ever, so i is curious that you are on your third

    i will send you another today

    kind regards


  • I agree that it is an odd coincidence. On the other hand, there is no doubt that the first two developed premature faults.

    I hope that this is the cause, because I am otherwise at a loss for an explanation.

    I appreciate that you are covering these part costs for an out-of-warranty machine, when you are under no obligation to do so. None of your competitors would go so far for customer service.

  • The new heating element fixed the problem. Hopefully this thread is done for good.

  • man that's bizarre. a first time for everything i suppose. have a good xmas! reiss.

Sign In or Register to comment.